Filesystem problems sidestepped

From: greg scott <>
Date: Sat Jan 01 2005 - 18:41:53 PST

Andy Valencia <> writes:

> Zx exits without writing the block (I know, I need to add that to the doc).

is there an easy way to view the source, aside from the ForthOS editor?

while using the ForthOS editor to view the file "vi", i wondered if
there was a good way to view source under unix.

the CD has a monolithic SrcFS1000 file which isnt easy to grep or view
in a unix editor (ex. emacs).

anyway, the ForthOS editor did let me find the useful Forth-vi commands:
ZN, ZP (and Zx which you provided).

so using the ForthOS editor just got less painful, but i wonder if
there is any easier way to view the source from unix.

> You can now sidestep the editor entirely; just 20000 block update,
> and then see if "sync" hangs. We're then looking at the question of
> whether something's hosed in the IDE controller, or just the block
> buffer code.

sorry i cant try "20000 block update", since i've made the problem
disappear through repartitioning. everything works fine now, including
fs.mkdir and of course "20000 block update".

a user having problems like mine would be advised to try another disk,
or at least try repartitioning the same disk differently (since no
operation with the existing partitions got rid of the problem).

before today, about the only thing i hadnt tried on the problem
partition was changing its size. moving to a diffent IDE controller,
partition recreation, various mkfs operations prior to marking the
partition as type 9E, using linux and FreeBSD to create the type 9E
(158) partition...nothing worked.

today, i wiped the Forth partition, booted into FreeBSD-5.3, recreated
the type 158 partition, used (BSD) dd exactly as your webpage
describes, and reproduced the problem.

so then i wiped everything off the disk and repartitioned it with
different sizes, and repeated exactly my original (slackware)
linux-based ForthOS installation. this time everything works fine.

thank you for helping with this problem, it must have been my problem,
not your code.

Received on Sat, 01 Jan 2005 20:41:53 -0600

This archive was generated by hypermail 2.1.8 : Tue Sep 26 2006 - 09:03:02 PDT