ForthOS installation problem

From: Antonio Maschio <>
Date: Fri Feb 18 2005 - 02:08:07 PST

I tried to install ForthOS on my computer, but things didn't go as I hoped.

Now, my situation is the following:

- HD #1 (40 GB) with a bunch of partitions:
        1 for windows (hda1, primary),
        2 storage for Linux (hda2, primary) and
        3 Red Hat 9A, /, /usr, /opt, /home and two swap partitions all
          contained in an extended partition (hda3)
- HD #2 (80 GB) with 3 primary partition, the first (20 GB) with a
   vfat32 filesystem, the second (40 GB) wIth a Linux 83 partition and
the third (20 GB) with a 158 partition (9e in hex) for ForthOS (is is
too much?).

I configured Grub to load RedHat, Windows and ForthOS (the latter with the

root= (hd1,2)
kernel= 8+700


I then executed the following, as root (Linux version of dd).

# dd bs=4k skip=1 seek=1 if=ForthOS1 of=/dev/hdb3
# dd bs=4k seek=100 if=ForthOS2 of=/dev/hdb3
# dd bs=4k seek=10000 if=SrcFS10000 of=/dev/hdb3

What I obtain is that, at boot, ForthOS starts, but a fs.root! reports
a message (I recall it by heart) "Corrupt Block??"

If I print the drivers.ideoff variable, it is 0.

What's wrong with my setting?

I tried even resizing the second and third partitions, shrinking the
ForthOS to 500 MB, but, as before,ForthOS boots, with no HD under it
(or, to say it better, with the HD #1 under it).

1. Maybe ForthOS must be installed in the first HD? Does it look for a 158
partition only on the first HD, though Grub makes it regularly boot?
2. Or 20 GB are too much, and ForthOS can't manage them?
3. Or the linux dd version doesn't work the same way as UNIX one?

Please, if someone has met the same problem, help me.

If there's need for more data about my computer, or the ForthOs
installation I executed, just ask.

Thank you.

Greetings from a cold North Italy

Antonio Maschio
Received on Fri, 18 Feb 2005 09:08:07 -0100

This archive was generated by hypermail 2.1.8 : Tue Sep 26 2006 - 09:03:04 PDT